阿里云虚拟主机安装wordpress出现500错误怎么解决?

阿里云知识 阿里云知识 4年前 (2019-08-02) 82次浏览 0个评论 扫描二维码

博客新搭建使用的是阿里云虚拟主机,然后下载的是最新的wordpress程序,但是很奇怪,安装是成功了,前端页面能打开,但是就是后台打开时报500错误!!!

这是什么怎么回事?500错误是服务器错误唉,既然前端页面能打开,说明与服务器连接正常了啊?!

不对?!难道是cms后端文件夹权限问题?导致服务器没有权限访问?

然后就去把相应文件夹的权限设置为:755(将应用改变到所有子文件夹和文件),然而并不是这个问题,没办法,只能继续找原因了。

突然想到:有没有这种可能性,wordpress对服务器的要求与阿里云服务器配置不匹配导致的呢?

马上去wordpress官网查了一下服务器要求:

其中有一条要求php版本至少:5.2以上版本,而查看阿里云虚拟服务器的php版本,默认的是5.2,瞬间无语,最后,我们只需要在阿里云服务器后台修改一下php版本号即可。

备注:这里有个坑爹的地方,由于我们之前已经成功安装了 wordpress,但是阿里云修改php版本号要将数据库密码的加密模式改为:41位加密,因此,我们在修改数据库密码的时候要保证密码跟之前的一样,只要改密码的加密模式就行了。

喜欢 (0)
阿里云最新优惠活动,点击查看
腾讯云最新优惠活动,点击查看
腾讯云香港及海外免备案服务器优惠活动,点击查看
华为云服务器本周优惠活动,点击查看

文章评论已关闭!